TwinTurbo.NET: Nissan 300ZX forum - Misfire advice
People Seeking Info
 
   


     
Subject Misfire advice
     
Posted by AirGuardZ on December 17, 2010 at 3:07 PM
  This message has been viewed 386 times.
     
     
Message Having trouble correcting a misfire in aft driver-side cylinder. Here are the symptoms:

Engine idle: Constant misfire
Parked, revving engine: Constant misfire
Driving, cruise throttle: Constant misfire
Driving, acceleration throttle: misfire goes away most of the time. When the engine smooths out, it stays gone until cruise throttle or (sometimes) acceleration in the next gear.
Driving, wide open throttle: same as above
The car used to eliminate the misfire as it warmed up, but this no longer happens.
All symptoms verified by obvious rough running and a sudden drop/lack of rise in EGT from the left cylinder bank sensor.

Steps I've taken so far:
Isolated cylinder by pulling injector clips and listening for RPM drop
Replaced spark plugs and applied dielectric grease
Cleaned throttle bodies
Cleaned corrosion from PTU harness connections and applied dielectric grease.
Tried adjusting idle air/fuel mixture with Apexi AFC.

Car is a 1991 Twin Turbo, with mods to support ~430 RWHP.

If anyone has any go-to post links please post them. For some reason when I try to search, the connection resets every time.

Thanks for any advice. Would love to be rid of this annoying problem.

-Kel

     
Follow Ups  
     
Post a
Followup

You cannot reply to this message because you are not logged in.